html5教程-HDU GCC(HDU 3123)解题报告

发布时间:2018-12-18 发布网站:脚本宝典
脚本宝典收集整理的这篇文章主要介绍了html5教程-HDU GCC(HDU 3123)解题报告脚本宝典觉得挺不错的,现在分享给大家,也给大家做个参考。
小宝典致力于为广大程序猿(媛)提供高品质的代码服务,请大家多多光顾小站,小宝典在此谢过。

/*Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2646    Accepted Submission(s): 810


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

 

Sample Input
1
10 861017
 

Sample Output
593846
*/

[html]
#include<stdio.h> 
#include<stdlib.h> 
#include<string.h> 
char n[1010]; 
__int64 m; 
int main() 

 __int64 num,sum=0; 
 int i,T,m,k; 
 scanf("%d",&T); 
 while(T--) 
 { 
  scanf("%s%d",n,&m); 
        if(strlen(n)>=7) 
      k=m; 
  else 
           k=atoi(n); 
     num=1,sum=1; 
     for(i=1;i<=k;i++) 
  { 
          num=(num*i)%m; 
    sum=(sum+num)%m; 
  } 
     printf("%I64d/n",sum%m); 
 } 
 return 0; 

作者:xieqinghuang

/*Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2646    Accepted Submission(s): 810


Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m

 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

 

Sample Input
1
10 861017
 

Sample Output
593846
*/

[html]
#include<stdio.h> 
#include<stdlib.h> 
#include<string.h> 
char n[1010]; 
__int64 m; 
int main() 

 __int64 num,sum=0; 
 int i,T,m,k; 
 scanf("%d",&T); 
 while(T--) 
 { 
  scanf("%s%d",n,&m); 
        if(strlen(n)>=7) 
      k=m; 
  else 
           k=atoi(n); 
     num=1,sum=1; 
     for(i=1;i<=k;i++) 
  { 
          num=(num*i)%m; 
    sum=(sum+num)%m; 
  } 
     printf("%I64d/n",sum%m); 
 } 
 return 0; 

作者:xieqinghuang

觉得可用,就经常来吧! 脚本宝典 欢迎评论哦! html5教程,巧夺天工,精雕玉琢。小宝典献丑了!

脚本宝典总结

以上是脚本宝典为你收集整理的html5教程-HDU GCC(HDU 3123)解题报告全部内容,希望文章能够帮你解决html5教程-HDU GCC(HDU 3123)解题报告所遇到的问题。

如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典推荐好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。
标签:HTML