html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用

发布时间:2018-12-18 发布网站:脚本宝典
脚本宝典收集整理的这篇文章主要介绍了html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用脚本宝典觉得挺不错的,现在分享给大家,也给大家做个参考。
小宝典致力于为广大程序猿(媛)提供高品质的代码服务,请大家多多光顾小站,小宝典在此谢过。

Intelligent IME
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 386    Accepted Submission(s): 203


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn
 

Sample Output
3
2
0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding
 
题意:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
 
a 是2 b是2 c 是2  d是3 e是3.。。。。。。。
把字符串转化以后的数字串  看在上面出现了几次
理所当然 map解决
这题主要是练习 map 和char[] 的合作
 
[html] 
#include<stdio.h> 
#include<string.h> 
#include<string> 
#include<iostream> 
#include<map> 
using namespace std; 
char key[27]="22233344455566677778889999"; 
char num[5005][10],word[5005][10]; 
int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        int n,m,i,j,len; 
        map <string,int> M; 
        scanf("%d%d",&n,&m); 
        for(i=0;i<n;i++) 
        { 
            scanf("%s",num[i]); 
        } 
        map<string,int>::iterator it;  
        for(i=0;i<m;i++) 
        { 
            scanf("%s",word[i]); 
            len=strlen(word[i]); 
            for(j=0;j<len;j++) 
                word[i][j]=key[word[i][j]-'a']; 
            it=M.find(word[i]); 
            if(it==M.end()) 
                M[word[i]]=1; 
            else 
                M[word[i]]++; 
        }     
        for(i=0;i<n;i++) 
        { 
            it=M.find(num[i]); 
            if(it==M.end()) 
                printf("0/n"); 
            else 
                printf("%d/n",M[num[i]]); 
        } 
    } 
    return 0; 

Intelligent IME
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 386    Accepted Submission(s): 203


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn
 

Sample Output
3
2
0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding
 
题意:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
 
a 是2 b是2 c 是2  d是3 e是3.。。。。。。。
把字符串转化以后的数字串  看在上面出现了几次
理所当然 map解决
这题主要是练习 map 和char[] 的合作
 
[html] 
#include<stdio.h> 
#include<string.h> 
#include<string> 
#include<iostream> 
#include<map> 
using namespace std; 
char key[27]="22233344455566677778889999"; 
char num[5005][10],word[5005][10]; 
int main() 

    int t; 
    scanf("%d",&t); 
    while(t--) 
    { 
        int n,m,i,j,len; 
        map <string,int> M; 
        scanf("%d%d",&n,&m); 
        for(i=0;i<n;i++) 
        { 
            scanf("%s",num[i]); 
        } 
        map<string,int>::iterator it;  
        for(i=0;i<m;i++) 
        { 
            scanf("%s",word[i]); 
            len=strlen(word[i]); 
            for(j=0;j<len;j++) 
                word[i][j]=key[word[i][j]-'a']; 
            it=M.find(word[i]); 
            if(it==M.end()) 
                M[word[i]]=1; 
            else 
                M[word[i]]++; 
        }     
        for(i=0;i<n;i++) 
        { 
            it=M.find(num[i]); 
            if(it==M.end()) 
                printf("0/n"); 
            else 
                printf("%d/n",M[num[i]]); 
        } 
    } 
    return 0; 

觉得可用,就经常来吧! 脚本宝典 欢迎评论哦! html5教程,巧夺天工,精雕玉琢。小宝典献丑了!

脚本宝典总结

以上是脚本宝典为你收集整理的html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用全部内容,希望文章能够帮你解决html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用所遇到的问题。

如果觉得脚本宝典网站内容还不错,欢迎将脚本宝典推荐好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。
标签:HTML